Installation de Moodle sur un hébergement mutualisé OVH

Aujourd’hui, petit coup de pouce technique sur l’installation de Moodle chez l’hébergeur OVH.

J’ai eu de nombreuses fois à installer le LMS Moodle sur un hébergement mutualisé OVH, que ce soit pour les besoins d’une démo ou pour un client. Mais depuis la version 3.3 de Moodle, les pré-requis en terme de base de données ont changé et il n’est plus possible par défaut de finaliser l’installation. Voici l’astuce de contournement du problème.

1. Lancer l’installation

2. Vérification des paramètres serveur

Au moment de la vérification, deux tests échouent :

  • unsupported_db_table_row_format
  • mysql_full_unicode_support

3. Récupérer le fichier config.php

Connectez-vous en FTP au serveur et récupérer le fichier config.php qui vient d’être créé automatiquement à la racine du dossier de Moodle.

4. Modifier une ligne

Ouvrez ce fichier et remplacer la ligne :

'dbcollation' => 'utf8bm4_unicode_ci',

par :

'dbcollation' => 'utf8_unicode_ci',

5. Remplacer le fichier config.php

Par la nouvelle version.

6. Actualiser la page de test des pré-requis serveur

Les deux erreurs qui empêchaient d’aller plus loin deviennent de simples avertissements et vous pouvez finaliser l’installation.

Bien évidemment, les avertissements pourraient être bloquant dans le futur selon votre utilisation de Moodle et il faudra y être attentif. Pour un client, je privilégierais une configuration du serveur parfaite, mais pour le moment, vous pouvez finaliser votre installation et commencer à paramétrer votre Moodle.

Source : https://www.fxparlant.net/installer-moodle-sur-ovh-contourner-lerreur-de-base-de-donnee-et-dunicode/

 

Archives